hdu2859 最大对称矩阵

Problem Description
Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix:
cbx
cpb
zcc

Input
There are several test cases in the input file. Each case starts with an integer n (0< n< =1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.

Output
Each test case output one line, the size of the maximum symmetrical sub- matrix.

Sample Input
3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0

Sample Output
3
3

dp[i][j] 表示以 (i,j) 为起始坐标的时候的最大对称矩阵大小

那么每一次dp[i][j]   都可以由 dp[i-1][j+1] 推出 只要满足条件即可

注意特殊情况一个字母的时候 输出1

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e3+5;
int n;
char ma[maxn][maxn];
int dp[maxn][maxn];
void init(){
	memset(dp,0,sizeof(dp));
}
int main(){
	while(~scanf("%d",&n)&&n){
		init();
		for(int i=0;i<n;i++){
			scanf("%s",ma[i]);
		}
		int ans=1;  //起初一定要为1 记为一个字母时候! 
		for(int i=0;i<n;i++){
                for(int j=n-1;j>=0;j--){
                  dp[i][j] = 1;
                  if(i==0 || j==n-1) continue;
                  int k=dp[i-1][j+1];
                  for(int s=1;s<=k;s++){
                      if(ma[i-s][j] == ma[i][j+s]) dp[i][j]++;
                      else break;
                }
                ans=max(ans,dp[i][j]);
            }
        }
//		for(int i=0;i<n;i++){
//			for(int j=0;j<n;j++){
//				printf("%c ",ma[i][j]);
//			}
//			puts("");
//		}
//		
//		for(int i=0;i<n;i++){
//			for(int j=0;j<n;j++){
//				printf("(%d%d)%d ",i,j,dp[i][j]);
//			}
//			puts("");
//		}
		printf("%d\n",ans);
		
	}
	return 0;
}

  

 

posted @ 2019-08-20 17:36  杰瑞与汤姆  阅读(398)  评论(0编辑  收藏  举报