POJ 2656 Unhappy Jinjin

时间限制: 
1000ms
内存限制: 
65536kB
描述
Jinjin is a junior school student. Besides the classes in school, Jinjin's mother also arranges some supplementary classes for her. However, if Jinjin studies for more than eight hours a day, she will be unhappy on that day. On any day she gets unhappy, the more time she studies, the unhappier she will be. Now we got Jinjin's class schedule for the next several days and your task is to find out whether she will be unhappy on these days; if she will be unhappy, on which day she will be the unhappiest.
输入
There may be several test cases. In the first line of each test case, there is an integer N (1 <= N <= 7), which represents the number of days you should analyze. Then there comes N lines, each contains two non-negative integers (each smaller than 10). The first integer represents how many hours Jinjin studies at school on the day, and the second represents how many hours she studies in the supplementary classes on the same day.

A case with N = 0 indicates the end of the input, and this case should not be processed.
输出
For each test case, output a line contains a single integer. If Jinjin will always be happy, the integer should be 0; otherwise, the integer should be a positive integer K, which means that Jinjin will be the unhappiest on the K-th day. If the unhappiest day is not unique, just output the earliest one among these unhappiest days.
样例输入
75 36 27 25 35 40 40 614 40
样例输出
30
 
(1)、源代码:
#include <iostream>
using namespace std;
 
int main(){
                int i, n, a, b;
 
                while(1){
                                cin >> n;
                                if(0 == n)
                                                break;
                                int mday, mhour = -1;
                                for(i = 1; i <=n ; i++){
                                                cin >> a >> b;
                                                if(a+b > mhour){
                                                                mhour = a+b;
                                                                mday = i;
                                                }
                                }
                                if(mhour <=8)
                                                cout << "0\n";
                                else
                                                cout << mday << endl;
                }
                return 0;
}
  
(2)、可能出错:略
(3)、解题思路:略
posted on 2012-05-11 20:16  谷堆旁边  阅读(270)  评论(0编辑  收藏  举报