POJ 1218 THE DRUNK JAILER

时间限制: 
1000ms
内存限制: 
65536kB
描述
A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He
repeats this for n rounds, takes a final drink, and passes out.
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.
Given the number of cells, determine how many prisoners escape jail.
输入
The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.
输出
For each line, you must print out the number of prisoners that escape when the prison has n cells.
样例输入
25100
样例输出
210
 
(1)、源代码:
#include <iostream>
#include <cmath>
using namespace std;
 
int main(){
                int i, n, a;
 
                cin >> n;
                while(n-- > 0){
                                cin >> a;
                                i = sqrt(1.0 * a);
                                cout << i << endl;
                }
                return 0;
}
  
(2)、解题思路:这道题研究清楚了其实就是求小于n的平方数有几个。或者求1到n哪些数被操作过奇数次也行。
(3)、可能出错:略
 
posted on 2012-05-11 20:15  谷堆旁边  阅读(213)  评论(0编辑  收藏  举报