POJ 1003 Hangover

时间限制: 
1000ms
 
内存限制: 
65536kB
描述

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make ncards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.


输入
The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
输出
For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
样例输入
1.003.710.045.190.00
样例输出
3 card(s)61 card(s)1 card(s)273 card(s)
 
(1)、源代码:
#include <iostream>
using namespace std;
 
int main(){
                int i;
                double length,sum;
                
                while(1){
                                cin >> length;
                                sum = 0;
                                if(length == 0.00)
                                                break;
                                for(i = 1; i < 300; i++){
                                                sum += 1.0/(i+1);
                                                if(sum >= length){
                                                                cout << i << " card(s)\n";
                                                                break;
                                                }
                                }
                }
                return 0;
}
  
(2)、解题思路:略
(3)、可能出错:略
 
posted on 2012-05-02 22:03  谷堆旁边  阅读(206)  评论(0编辑  收藏  举报