PAT Basic 1046
1046 划拳 (15 分)
划拳是古老中国酒文化的一个有趣的组成部分。酒桌上两人划拳的方法为:每人口中喊出一个数字,同时用手比划出一个数字。如果谁比划出的数字正好等于两人喊出的数字之和,谁就赢了,输家罚一杯酒。两人同赢或两人同输则继续下一轮,直到唯一的赢家出现。
下面给出甲、乙两人的划拳记录,请你统计他们最后分别喝了多少杯酒。
输入格式:
输入第一行先给出一个正整数 N(≤100),随后 N 行,每行给出一轮划拳的记录,格式为:
甲喊 甲划 乙喊 乙划
其中喊
是喊出的数字,划
是划出的数字,均为不超过 100 的正整数(两只手一起划)。
输出格式:
在一行中先后输出甲、乙两人喝酒的杯数,其间以一个空格分隔。
输入样例:
5
8 10 9 12
5 10 5 10
3 8 5 12
12 18 1 13
4 16 12 15
输出样例:
1 2
这里的if判断写的稍微复杂了点,这样就可以了,另外两种不需要执行
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include <vector>
#include<algorithm>
#include<string>
#include<math.h>
#define max 1000
#define debug 0
using namespace std;
int main() {
#if debug
freopen("in.txt", "r", stdin);
#endif
int n = 0;
cin >> n;
int jiahan, jiahua, yihan, yihua,jiahe=0,yihe=0;
for (int i = 0; i < n; i++)
{
cin >> jiahan >> jiahua >> yihan >> yihua;
if (jiahua == jiahan + yihan)
{
if (yihua == jiahan + yihan)
continue;
else
yihe++;
}
else
{
if (yihua == jiahan + yihan)
jiahe++;
else
continue;
}
}
cout << jiahe <<' '<< yihe<<endl;
#if debug
freopen("CON", "r", stdin);
#endif
return 0;
}