PAT Basic 1007
1007 素数对猜想 (20 分)
让我们定义dn为:dn=pn+1−pn,其中pi是第i个素数。显然有d1=1,且对于n>1有dn是偶数。“素数对猜想”认为“存在无穷多对相邻且差为2的素数”。
现给定任意正整数N
(<105),请计算不超过N
的满足猜想的素数对的个数。
输入格式:
输入在一行给出正整数N
。
输出格式:
在一行中输出不超过N
的满足猜想的素数对的个数。
输入样例:
20
输出样例:
4
注意是不超过,n也需要算进去
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include <vector>
#include<algorithm>
#include<string>
#include<math.h>
#define max 100000
#define debug 0
using namespace std;
int main() {
#if debug
freopen("in.txt", "r", stdin);
#endif
int n = 0,a[max],num=0,count=0;
cin >> n;
for (int i = 2; i <=n; i++)
{
int j = 2;
for (; j <sqrt(i); j++)
{
if (i%j == 0)
break;
}
if (j > sqrt(i))
{
a[num++] = i;
}
}
for (int i = 0; i < num-1; i++)
{
if (a[i + 1] - a[i] == 2)
{
count++;
}
}
cout << count<<endl;
#if debug
freopen("CON", "r", stdin);
#endif
return 0;
}