N!
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描写叙述
首先非常感谢刘老师能给我这次机会给大家出题,希望大家做完题后能有所收获,假设有不论什么问题还请海涵。毕竟出套题不easy……TAT
题目总体不难,大体是给我带的大一新生出题的难度,所以请各位放心。
题目总体不难,大体是给我带的大一新生出题的难度,所以请各位放心。
If you want to learn something from other people, remember, stay hunger.---shadow95
Now, your first problem comes~
This task is very simple, please calculate how many zeros are there at the end of calculation of n!.
For example, 15! = 1307674368000, so answer is 3.
输入
At the first line, there is a number T indicating the number of test cases.
Then, following T lines, each line there is a number n (n<10^9).
Then, following T lines, each line there is a number n (n<10^9).
输出
For each case, output the case number and answer in one line.
演示样例输入
3 5 100 1024
演示样例输出
Case #1: 1 Case #2: 24 Case #3: 253
提示
来源
HDU shadow95
演示样例程序
- #include<stdio.h>
- #include<string.h>
- int fun(int n)
- {
- int sum=0;
- while(n)
- {
- n=n/5;
- sum+=n;
- }
- return sum;
- }
- int main()
- {
- int t, T, n;
- scanf("%d", &T);
- for(int t=1;t<=T;t++)
- {
- scanf("%d", &n);
- int re=fun(n);
- printf("Case #%d: %d\n", t, re);
- }
- return 0;
- }