Digging-贪心

When it comes to the Maya Civilization, we can quickly remind of a term called the end of the world. It's not difficult to understand why we choose to believe the prophecy (or we just assume it is true to entertain ourselves) if you know the other prophecies appeared in the Maya Calendar. For instance, it has accurately predicted a solar eclipse on July 22, 2009.

The ancient civilization, such as Old BabylonianhasAncient Egypt and etc, some features in common. One of them is the tomb because of the influence of the religion. At that time, the symbol of the tomb is the pyramid. Many of these structures featured a top platform upon which a smaller dedicatory building was constructed, associated with a particularMaya deity. Maya pyramid-like structures were also erected to serve as a place of interment for powerful rulers.

Now there are N coffin chambers in the pyramid waiting for building and the ruler has recruited some workers to work for Tdays. It takes ti days to complete the ith coffin chamber. The size of the ith coffin chamber is si. They use a very special method to calculate the reward for workers. If starting to build the ith coffin chamber when there are t days left, they can get t*si units of gold. If they have finished a coffin chamber, then they can choose another coffin chamber to build (if they decide to build the ith coffin chamber at the time t, then they can decide next coffin chamber at the time t-ti).

At the beginning, there are T days left. If they start the last work at the time t and the finishing time t-ti < 0, they will not get the last pay.

Input

There are few test cases.

The first line contains NT (1 ≤ N ≤ 3000,1 ≤ T ≤ 10000), indicating there are N coffin chambers to be built, and there areT days for workers working. Next N lines contains tisi (1 ≤ tisi ≤ 500).

All numbers are integers and the answer will not exceed 2^31-1.

Output

For each test case, output an integer in a single line indicating the maxminal units of gold the workers will get.

Sample Input

3 10
3 4
1 2
2 1

Sample Output

62

Hint

Start the second task at the time 10
Start the first task at the time 9
Start the third task at the time 6
The answer is 10*2+9*4+6*1=62

 

 

#include"iostream"
#include"algorithm"
#include"cstring"
#include"queue"
#include"cmath"
#include"cstdio"
#include"cstdlib"
using namespace std;
#define sr(x) scanf("%d",&x)
#define sc(x) printf("%d",x)
#define hh printf("\n")
#define mod 1000000007
#define MAX(x,y) (x>y?x:y)
struct PP
{
    int t,s;
};
int comp(PP x,PP y)
{
    double l1,l2;
    l1=(double)x.s*1.0/x.t;
    l2=(double)y.s*1.0/y.t;
    if(fabs(l1-l2)>0.00001)return l1>l2;
    return x.t<y.t;
}
int main()
{
    int n,tt,ss,ll[10002],i,j;
    while(scanf("%d%d",&n,&tt)!=EOF)
    {
        ss=0;
        PP dd[3001];
        for(i=0;i<n;i++)
        {
            sr(dd[i].t);sr(dd[i].s);
        }
        memset(ll,0,sizeof(ll));
        sort(dd,dd+n,comp);
        for(i=0;i<n;i++)
        {
            for(j=tt;j>=dd[i].t;j--)
            {
                ll[j]=MAX(ll[j],ll[j-dd[i].t]+dd[i].s*(tt-j+dd[i].t));
                ss=MAX(ss,ll[j]);
            }
        }
        printf("%d\n",ss);
    }
    return 0;
}

 

posted on 2013-11-12 21:11  lveternal  阅读(153)  评论(0编辑  收藏  举报

导航