浙大 pat 1038 题解

1038. Recover the Smallest Number (30)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287





#include"iostream"
#include "algorithm"
#include <sstream>
#include"string.h"
#include "vector"
using namespace std;


bool mycompare(string s1,string s2)
{
return s1+s2<s2+s1;
}


int main()
{
int n;
cin >> n;
vector<string> num;
string str;
for(int i=0;i<n;i++)
{
cin >> str;
num.push_back(str);
}
sort(num.begin(),num.end(),mycompare);
string strs;
for(int i=0;i<n;i++)
strs += num[i];
int non_zero = -1;
for(int i=0;i<strs.size();i++)
{
if(strs[i]!='0')
{
non_zero = i;
break;
}

}
if(non_zero == -1)
cout <<"0"<<endl;
else
{
strs = strs.substr(non_zero);
cout<<strs<<endl;
}

return 0;
}

posted @ 2013-09-13 16:33  路萧  阅读(199)  评论(0编辑  收藏  举报