浙大pat 1031题解

1031. Hello World for U (20)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

 

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor




#include"iostream"
#include "algorithm"
#include "string"
#include "vector"
using namespace std;

void OutPut(string s)
{
int n = s.size();
int n1,n2;
for(n2=3;n2<=n;n2++)
{
int temp = n+2-n2;
if(temp%2!=0)
continue;
n1 = temp/2;
if(n1<=n2)
break;
}

for(int i=0;i<n1;i++)
{
cout<<s[i];
if(i!=n1-1)
{
for(int t=0;t<n2-2;t++)
cout<<" ";
}
else
{
int k = i+1;
for(int j=0;j<n2-2;++j,++k)
cout<<s[k];
}
cout<<s[n-1-i];
cout<<endl;
}

}
int main()
{
string s;
cin >> s;
OutPut(s);

return 0;
}

posted @ 2013-09-07 13:27  路萧  阅读(252)  评论(0编辑  收藏  举报