HDU-2859_Phalanx

Phalanx

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3093 Accepted Submission(s): 1510

Problem Description

Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix:
cbx
cpb
zcc

Input

There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.

Output

Each test case output one line, the size of the maximum symmetrical sub- matrix.

Sample Input

3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0

Sample Output

3
3

Source

2009 Multi-University Training Contest 5 - Host by NUDT

Recommend

gaojie

题意:找最大对称子矩阵(沿用上角到左下角的对角线对称)。
题解:dp遍历每一个点,比较这一个点所在的列上边和所在行的右边对称的数目,如果大于dp[i-1][j+1],则dp[i][j] = dp[i-1][j+1] + 1,否则等于对称的数目。

#include <iostream>
#include <stdio.h>
#include <cstdlib>
#include <cstring>
#include <cmath>

using namespace std;

const int maxn = 1050;

char s[maxn][maxn];
int dp[maxn][maxn];

int main()
{
    int n,i,j,Max,a,b;
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(i=0;i<n;i++)
            scanf("%s",s[i]);
        Max = 0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                if(i==0||j==n-1)
                {
                    dp[i][j] = 1;
                }
                else
                {
                    a = i;
                    b = j;
                    while(a>=0&&b<n&&s[a][j] == s[i][b])
                    {
                        a--;
                        b++;
                    }
                    if(i-a>=dp[i-1][j+1] + 1)
                        dp[i][j] = dp[i-1][j+1] + 1;
                    else
                        dp[i][j] = i - a;
                }
                Max = max(Max,dp[i][j]);
            }
        }
        printf("%d\n",Max);
    }
    return 0;
}
posted @ 2018-10-15 15:17  洛沐辰  阅读(131)  评论(0编辑  收藏  举报