POJ-1125_Stockbroker Grapevine
Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Description
Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.
Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
Input
Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.
Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.
Output
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
Sample Output
3 2
3 10
题意:多组输入,n个人,每个人可以个其他m个人传递消息,给ai传递消息的耗时为bi(i<m),求选择那个人传递消息比较快,耗时多少。若无法传递给所有人则输出“disjoint”。
题解:这道题题目十分冗杂,而且把关键信息都掺杂在题目里,但读懂了题目就简单了,以每个人为原点进行最短路求值,求出其到达其他人的最长的那一条,然后求这些里面最短的就可以了。数据量比较小,用Dijkstra算法就可以。
#include <queue>
#include <cmath>
#include <stack>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 255;
const int INF = 1e9 + 7;
int s[maxn][maxn],n;
int Dij(int a)
{
int f[maxn],dis[maxn],i,j,MIN,k;
for(i=1;i<=n;i++)
{
dis[i] = s[a][i];
f[i] = 0;
}
f[a] = 1;
dis[a] = 0;
for(i=0;i<n;i++)
{
MIN = INF;
k = -1;
for(j=1;j<=n;j++)
{
if(!f[j]&&dis[j]<MIN)
{
MIN = dis[j];
k = j;
}
}
if(MIN == INF)
break;
f[k] = 1;
for(j=1;j<=n;j++)
if(!f[j]&&dis[k]+s[k][j]<dis[j])
dis[j] = dis[k] + s[k][j];
}
MIN = -1;
for(i=1;i<=n;i++)
MIN = max(MIN,dis[i]);
return MIN;
}
int main()
{
int MIN,i,j,m,a,b,k;
while(scanf("%d",&n)!=EOF&&n)
{
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
s[i][j] = i==j?0:INF;
for(i=1;i<=n;i++)
{
scanf("%d",&m);
for(j=0;j<m;j++)
{
scanf("%d%d",&a,&b);
if(b<s[i][a])
s[i][a] = b;
}
}
MIN = INF;
for(i=1;i<=n;i++)
{
a = Dij(i);
if(a<MIN)
{
MIN = a;
k = i;
}
}
if(MIN==INF)
printf("disjoint\n");
else
printf("%d %d\n",k,MIN);
}
return 0;
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· 使用C#创建一个MCP客户端
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 按钮权限的设计及实现