POJ-3159_Candies

Candies

Time Limit: 1500MS Memory Limit: 131072K

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

题意:给n个人派糖果,给出m组数据,每组数据包含A,B,c 三个数,意思是A的糖果数比B少的个数不多于c,即B的糖果数 - A的糖果数<= c 。最后求小孩中的最大差值是多少。
题解:这是一题典型的差分约束题,可以把糖果看成距离,然后就是求最短路的问题了。
由 dis[B]-dis[A]<=w(A,B)。看到这里,我们联想到求最短路时的松弛技术,即if(dis[B]>dis[A]+w(A,B), dis[B]=dis[A]+w(A,B)。
坑点就在于SPFA队列会超时,所以采取堆栈。

#include <iostream>
#include <cstdio>

using namespace std;

const int maxn = 30050;
const int INF = 1e9+7;

int q[maxn],head[maxn],f[maxn],dis[maxn];
int num,n;

struct node
{
    int to,next,w;
}edge[150050];

void add(int v,int u,int w)
{
    edge[num].to = u;
    edge[num].next = head[v];
    edge[num].w = w;
    head[v] = num++;
}

void SPFA()
{
    int i,top;
    for(i=1;i<=n;i++)
    {
        f[i] = 0;
        dis[i] = INF;
    }
    top = 0;
    dis[1] = 0;
    f[1] = 1;
    q[top++] = 1;
    while(top)
    {
        int u,v,w;
        u = q[top-1];
        f[u] = 0;
        top--;
        for(i=head[u];i!=-1;i=edge[i].next)
        {
            v = edge[i].to;
            w = edge[i].w;
            if(dis[u]+w<dis[v])
            {
                dis[v] = dis[u] + w;
                if(!f[v])
                {
                    f[v] = 1;
                    q[top++] = v;

                }
            }
        }
    }
    cout<<dis[n]<<endl;
}

int main()
{
    int m,i,a,b,c;
    scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++)
        head[i] = -1;
    num = 0;
    for(i=0;i<m;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        add(a,b,c);
    }
    SPFA();
    return 0;
}
posted @   洛沐辰  阅读(122)  评论(0编辑  收藏  举报
编辑推荐:
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
阅读排行:
· 使用C#创建一个MCP客户端
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 按钮权限的设计及实现
点击右上角即可分享
微信分享提示