SDUT-2117_数据结构实验之链表二:逆序建立链表

数据结构实验之链表二:逆序建立链表

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

Input

第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。

Output

依次输出单链表所存放的数据。

Sample Input

10
11 3 5 27 9 12 43 16 84 22

Sample Output

22 84 16 43 12 9 27 5 3 11

Hint

不能使用数组!

链表的建立方式之一

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

typedef struct node
{
    int data;
    struct node *next;
}link;

link *newlink()
{
    link *t;
    t = (link*)malloc(sizeof(link));
    t->next = NULL;
    return t;
}

link *create(int n)
{
    link *head,*q;
    int i;
    head = newlink();
    for(i=0;i<n;i++)
    {
        q = newlink();
        scanf("%d",&q->data);
        q->next = head->next;
        head->next = q;
    }
    return head;
}

void show(link *head)
{
    link *p;
    p = head->next;
    while(p)
    {
        if(p->next==NULL)
            printf("%d\n",p->data);
        else
            printf("%d ",p->data);
        p = p->next;
    }
}

int main()
{
    int n;
    link *head;
    scanf("%d",&n);
    head = create(n);
    show(head);
    return 0;
}
posted @ 2018-09-29 21:02  洛沐辰  阅读(183)  评论(0编辑  收藏  举报