HDU-1069_Monkey and Banana
Monkey and Banana
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
Source
University of Ulm Local Contest 1996
Recommend
JGShining
题意:给n种立方体的长宽高,每种立方体都有无限个,立方体叠的时候需要留出站立的空间,即上面的立方体长和宽要小于下方的,求可以用这些立方体叠多高。
题解:每种立方体可以摆三种不同的状态,存储三种状态后就是一个求上升子序列的变形了。注意输出格式。
#include <algorithm>
#include <iostream>
#include <cstdio>
using namespace std;
struct node
{
int a,b,h;
}x[105];
bool cmp(node a,node b)
{
if(a.a==b.a)
return a.b<b.b;
return a.a<b.a;
}
int main()
{
int n,a,b,c,i,k = 1,num,j,max_h,dp[105],max2;
while(scanf("%d",&n)!=EOF&&n!=0)
{
num = 0;
for(i=0;i<n;i++)
{
scanf("%d%d%d",&a,&b,&c);
x[num].h = c;
x[num].a = max(a,b);
x[num++].b = min(a,b);
x[num].h = b;
x[num].a = max(a,c);
x[num++].b = min(a,c);
x[num].h = a;
x[num].a = max(c,b);
x[num++].b = min(c,b);
}
sort(x,x+num,cmp);
max_h = 0;
for(i=0;i<num;i++)
{
max2 = 0;
for(j=0;j<i;j++)
{
if(x[j].a<x[i].a&&x[j].b<x[i].b&&dp[j]>max2)
max2 = dp[j];
}
dp[i] = max2 + x[i].h;
max_h = max(max_h,dp[i]);
}
printf("Case %d: maximum height = %d\n",k++,max_h);
}
return 0;
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· 使用C#创建一个MCP客户端
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 按钮权限的设计及实现