Java练习 SDUT-2272_Time

Time

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.

Input

There are several test cases.
Each case contains 4 integers in a line, separated by space.
Proceed to the end of file.

Output

For each test case, output the time expressed by the digital clock such as Sample Output.

Sample Input

1 2 5 6
2 3 4 2

Sample Output

一道绘图题,这种题一直是弱项,头铁强制画了出来,浪费了挺多时间。而且整个人都狂燥了。
结果看到这份代码

  • z_xindong的代码
    瞬间清醒了,其实用三维数组存一下就可以了。(String开二维就好)
import java.util.Scanner;
 
public class Main{
 
	public static void main(String[] args) {
		Scanner cin=new Scanner(System.in);
		 String[][] time=new String[][]{
                 {" _ ","   "," _ "," _ ","   "," _ "," _ "," _ "," _ "," _ "},
                 {"| |","  |"," _|"," _|","|_|","|_ ","|_ ","  |","|_|","|_|"},
                 {"|_|","  |","|_ "," _|","  |"," _|","|_|","  |","|_|"," _|"}};
		    
		while(cin.hasNext()){
			int[] a=new int[4];
			for(int i=0;i<4;i++){
				a[i]=cin.nextInt();
			}
			for (int i = 0; i < 3; i++) {
				for (int j = 0; j < 4; j++) {
					System.out.print(time[i][a[j]]);
				}
				System.out.println();
			}			
		}
	} 
}
posted @   洛沐辰  阅读(186)  评论(0编辑  收藏  举报
编辑推荐:
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
阅读排行:
· 使用C#创建一个MCP客户端
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· ollama系列1:轻松3步本地部署deepseek,普通电脑可用
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 按钮权限的设计及实现
点击右上角即可分享
微信分享提示