字符串最后一个单词的长度(华为在线训练)

描述

计算字符串最后一个单词的长度,单词以空格隔开。

知识点 字符串,循环
运行时间限制 0M
内存限制 0
输入

一行字符串,长度小于128。

输出

整数N,最后一个单词的长度。

样例输入 hello world
样例输出 5

 

 

#include <stdio.h>

#include <string.h>

#include LEN 1024

int main(void)

{

  int len, i, j;

  char str[LEN];

  gets(str);

  len = strlen(str);

  if (0 == len)

  {

    return 0;

  }

  if (128 < len)

  {

    return -1;

  }

  i = len -1;

  j = 0;

  while(i>=0 && str[i] == ' ')

  { i-- ;}

  while(i>=0 && str[i] != ' ')

  {

    i--;

    j++;

   }

  printf("%d\n", j);

  return 0;

}

posted on 2015-08-30 20:16  IT小不点  阅读(240)  评论(0编辑  收藏  举报