HDU 2899 Strange fuction
Strange fuction
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11746 Accepted Submission(s): 7841
Problem Description
Now, here is a fuction:
F(x) = 6 * x^7 +8* x^6 + 7x^ 3+5x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input
2
100
200
Sample Output
-74.4291
-178.8534
Author
Redow
Recommend
lcy
这个题可以三分求单调性,也可以求导再进行计算。
#include<iostream>
#include<cstdio>
using namespace std;
double F(double x,double y)
{
return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
double f(double x)//易知导函数单调递增,则原函数先减后增;
{
return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;
}
int main()
{
int t;
double y,l,h,mid;
cin>>t;
while(t--)
{
cin>>y;
l=0.0;h=100.0;
while(h-l>1e-7)
{
mid=(l+h)/2;
if(f(mid)<y) l=mid;
else h=mid;
}
printf ("%.4lf\n",F(mid,y));
}
return 0;
}