HDU2937 YAPTCHA(威尔逊定理)

YAPTCHA
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2041 Accepted Submission(s): 1047

Problem Description
The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.

However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute

where [x] denotes the largest integer not greater than x.

Input
The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).

Output
For each n given in the input output the value of Sn.

Sample Input
13
1
2
3
4
5
6
7
8
9
10
100
1000
10000

Sample Output
0
1
1
2
2
2
2
3
3
4
28
207
1609
设P=3K+7即可,每当p是素数,值就加一完事了

#include <algorithm>
#include <cstdio>
#include <vector>
#include <iostream>
using namespace std;
typedef long long ll;
//const ll mod=1e9+7;
bool pri[3000036];int s[1000036];
int main()
{
    for(int i=0;i<3000010;i++)
        pri[i]=true;
    for(int i=2;i*i<3000010;i++)
        if(pri[i])
            for(int j=i*i;j<3000010;j+=i)
                pri[j]=false;
    s[1]=0;
    for(int i=12,j=2;i<=3000010;i+=3,j++)
    {
        if(pri[i+1])
            s[j]=s[j-1]+1;
        else
            s[j]=s[j-1];
    }
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        printf("%d\n",s[n]);
    }
}```
posted @ 2019-11-30 17:03  风骨散人  阅读(93)  评论(0编辑  收藏  举报