A1060 Are They Equal
题目要求
If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.
Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.
Output Specification:
For each test case, print in a line YES
if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k
(d[1]
>0 unless the number is 0); or NO
if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.
Note: Simple chopping is assumed without rounding.
Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3
题意
给出两个数,问:将他们写成保留N位小数的科学计数法后是否相等、如果相等,则输出YES,并给出该转换结果;如果不相等,则输出NO,并分别给出两个数的转换结果。
注意点
科学计数法形式按整数部分是否为0分为两种情况
0.ABCD...(这种情况还包含0.000...00ABCD)
ABC.DEF...
0.ABCD...
本体部分:是从小数点后第一个非零位开始的n位
指数部分:是小数点与第一个非零位之间0的个数的相反数
(例如0.001的指数为-2)
实现逻辑
令指数的初值e为0,然后小数点后每出现一个0,就让e-1(因为是相反数),直到出现非零位或者走到最后一位(有可能小数点后全为0)
ABC.DEF...
本体部分:从头开始的n位
指数部分:小数点前数位的总位数
实现逻辑
令指数的初值e为0,然后从前往后枚举,只要不到达最后一位或是出现小数点,就让e+1
陷阱
数据有可能出现前导0,例如000.01,00123.45
应对措施
在输入数据后的第一步就是去除所有前导0,这样就可以按去除前导0后的字符串的第一位是否是小数点来判断属于哪种类型
比较方法
处理第一种类型
将前导0,小数点,第一个非0位前的0全部删除,只保留第一个非0位开始的部分
处理第二种类型
将前导0,小数点删除,若长度不足n,则在后面补0
最后只要比较本体部分与指数是否都相等,决定输出YES或NO
代码
#include<iostream>
#include<string>
using namespace std;
int n; //有效位数
string deal(string s, int& e) {
int k = 0; //s的下标
while (s.length() > 0 && s[0] == '0') {
s.erase(s.begin()); //去掉s的前导0
}
if (s[0] == '.') { //去掉了前导0第一位是.,说明s是第一种类型的数
//将前导0,小数点,第一个非0位前的0全部删除,只保留第一个非0位开始的部分
s.erase(s.begin()); //去掉小数点
while (s.length() > 0 && s[0] == '0') {
s.erase(s.begin()); //去掉小数点后非0位前的所有0
e--; //每去掉一个0,指数-1
}
}
else { //去掉了前导0第一位是数字,说明s是第2种类型的数
while (k < s.length() && s[k] != '.') {
k++; //下标右移
e++; //指数+1
}
//将前导0,小数点删除,若长度不足n, 则在后面补0
if (k < s.length()) { //while结束后,k<s.length(),说明碰到了小数点
s.erase(s.begin() + k); //把小数点删除
}
}
if (s.length() == 0) { //如果去掉前导0之后s的长度变成了0,说明这个数是0
e = 0;
}
int num = 0; //剩余的有效位数
k = 0; //剩余的下标
string res; //生成的结果
while (num < n) { //只要精度还没有到n
if (k < s.length()) //只要还有数字,就加到res末尾
res += s[k++];
else
res += '0'; //否则res末尾+0
num++; //精度+1
}
return res;
}
int main() {
string s1,s2, s3, s4;
cin >> n >> s1 >> s2;
int e1 = 0, e2 = 0;
s3 = deal(s1, e1);
s4 = deal(s2, e2);
if (s3 == s4 && e1 == e2) {
cout << "YES 0." << s3 << "*10^" << e1 << endl;
}
else {
cout << "NO 0." << s3 << "*10^" << e1 << "0." << s4 << "*10^" << e2 << endl;
}
return 0;
}
不知道为什么是部分正确