POJ 1014 Dividing

Dividing
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 48515   Accepted: 12207

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

============================================================================

这道题目上来先是用dfs尝试了下,从1-6的深度遍历,同时记录已经使用价值总和和未使用的价值总和,超过sum/2就返回假,等于sum/2返回真。本机测试效果蛮好的,结果TLE了。然后改用动归来解。数组b(习惯这么称呼)第k位为真表示能够将价值分为k与sum-k两种情况。依次把石头加入进去,更新b的值,末了再查看b[sum/2]的情况就行了。中途使用了对数对其加速,貌似不加速速度有些悲剧。
因为只用到sum/2大小的数组,·b可以设置小点。代码偷懒了,没去算b的大小。直接一个超大的弄上去了。
#include <iostream>
#include <stdio.h>
#include <bitset>
using namespace std;

bool solve(int* s,int sum)
{
	if(sum&1) return false;
	bitset<120000> b; b.reset(); b[0] = true;
	for(int i=0;i<6;++i)
	{
		for(int j=1;j<=s[i];j*=2)
		{
			int v = j*(i+1); s[i] -= j;
			for(int k = sum/2;k>=v;--k) b[k] = b[k-v] || b[k];
		}
		int v = s[i]*(i+1);
		if(v) for(int k = sum/2;k>=v;--k) b[k] = b[k-v] || b[k];
	}
	return b[sum/2];
}

int main()
{
	//freopen("1014.data","r",stdin);
	for(int n=1;;++n)
	{
		int s[6]; int sum = 0;
		for(int i=0;i<6;++i) {cin>>s[i];sum += s[i]*(i+1);}
		if(sum == 0) break;
		bool ok = solve(s,sum);
		cout<<"Collection #"<<n<<":"<<endl
			<<(ok?"Can":"Can't")<<" be divided."<<endl<<endl;
	};
	return 0;
}

  

posted @ 2012-12-29 15:21  lssnail  阅读(158)  评论(0编辑  收藏  举报