POJ 1012 Joseph

Joseph
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 42451   Accepted: 15971

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. 

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30

=======================================================================
假设上一局(第n局)出局的是p位置的人,下一局出局的人就是第(p-1+m)%(2*k-n)个人(移除上一局出局的人之后的排名).只要得到的p<k,那么就是不可行
可恶的是...1-14的k测试出来速度都很快.一闪而过...为啥提交了N次都说我超时..无语..唉...
#include <stdio.h>
int main()
{
	int k,ok=1,p=0,m,j;
	//freopen("1012.data","r",stdin);
	while(scanf("%d",&k) && k)
	{
		for(m=k;;++m,p=0,ok=1)
		{
			for(j=0;j<k && ok;++j) ok = !((p=(p-1+m)%(2*k-j))<k);
			if(ok) {printf("%d\n",m); break;}
		}
	}
	return 0;
}

  无奈了只能提交一个打表的..

#include <stdio.h>
int r[] = {2,7,5,30,169,441,1872,7632,1740,93313,459901,1358657,2504881,13482720,25779600};
int main()
{
	int k;
	while(scanf("%d",&k) && k)
		printf("%d\n",r[k-1]);
	return 0;
}

  提交成C内存占用100多K..为毛其他人的占用就4k呢..

posted @ 2012-12-17 21:48  lssnail  阅读(138)  评论(0编辑  收藏  举报