刘收获

导航

< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

统计

HDU 1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 154923    Accepted Submission(s): 37854


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 3 1 2 10 0 0 0
 

 

Sample Output
2 5
 

 

Author
CHEN, Shunbao
 

 

Source
 

 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1008 1021 1019 1003 1009 
 
 
/*-----------------------f[i-1]%7与f[i-2]%7都有0,1,2,3,4,5,6七种可能的取值,所以f[i]的取值最大有49种,也就是在49次计算
内,至少出现一次循环,当f[i-1]与f[i]等于1(f[1],f[2]等于1)的时候,即为循环出现,周期cycle = i - 2;----------------------*/
 
 
 

#include<iostream>
using namespace std;

int main()
{
int cycle,i; //周期
int f[50];
int a,b,n;
f[1] = f[2] = 1;
while(cin>>a>>b>>n,a+b+n)
{
for( i = 3;i <= 49;i++)
{
f[i] = (a*f[i-1] + b*f[i-2])%7;
if(f[i] == f[i-1] && f[i] == 1) break;
}
cycle = i - 2;
n = n%cycle;
if(n==0)
cout<<f[cycle]<<endl;
else
cout<<f[n]<<endl;
}
return 0;
}

 

posted on   沉疴  阅读(202)  评论(0编辑  收藏  举报

编辑推荐:
· AI与.NET技术实操系列:基于图像分类模型对图像进行分类
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
阅读排行:
· 25岁的心里话
· 闲置电脑爆改个人服务器(超详细) #公网映射 #Vmware虚拟网络编辑器
· 零经验选手,Compose 一天开发一款小游戏!
· 通过 API 将Deepseek响应流式内容输出到前端
· AI Agent开发,如何调用三方的API Function,是通过提示词来发起调用的吗
点击右上角即可分享
微信分享提示