IO-03. 求整数均值

本题要求编写程序,计算4个整数的和与平均值。题目保证输入与输出均在整型范围内。

输入格式:

输入在一行中给出4个整数,其间以空格分隔。

输出格式:

在一行中按照格式“Sum = 和; Average = 平均值”顺序输出和与平均值,其中平均值精确到小数点后1位。

输入样例:
1 2 3 4
输出样例:
Sum = 10; Average = 2.5
import java.util.Scanner;
public class Main {
     public static void main(String[] args)
         {
             Scanner input = new Scanner(System.in);
             int a = input.nextInt();
             int b = input.nextInt();
             int c = input.nextInt();
             int d = input.nextInt();
             double Average = (double)(a+b+c+d)/4;
             System.out.print("Sum = "+(a+b+c+d)+"; "+"Average = "+Average);
         }
}

 

posted @ 2014-09-05 16:11  winTeaer  阅读(351)  评论(0编辑  收藏  举报