向前走莫回头❤

【HDU 3037】Saving Beans(组合数取模)

Saving Beans
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3706 Accepted Submission(s): 1428

Problem Description
Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.

Input
The first line contains one integer T, means the number of cases.

Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime.

Output
You should output the answer modulo p.

Sample Input
2
1 2 5
2 1 5

Sample Output
3
3
Hint
Hint

For sample 1, squirrels will put no more than 2 beans in one tree. Since trees are different, we can label them as 1, 2 … and so on.
The 3 ways are: put no beans, put 1 bean in tree 1 and put 2 beans in tree 1. For sample 2, the 3 ways are:
put no beans, put 1 bean in tree 1 and put 1 bean in tree 2.

Source
2009 Multi-University Training Contest 13 - Host by HIT

【题意】[求在n中取不多于m个元素的取法再模p]
【题解】【组合数取模板子题】
**【要注意组合公式,由于是取不多于m个,则题目解的个数可以转换成求 SUM=C0n+m1+C1n+m1+C2n+m1+……+Cmn+m1
利用公式Crn=Crn+Cr1n1 == > sum=Cmn+m
SUM=C0n+m1(m=0)+C1n+m1(m=1)+C2n+m1(m=2)+…+Cmn+m1(m=m)
=C0n1+C1n+C2n+1….+Cmnm1
因为C0n1=C0n=1
所以式子可以利用Crn=Crn1+Cr1n1 ,进行化简最终得到Cmn+m
现在就是要求Cmn+m%p。】**

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
using namespace std;
ll n,m,t,p;
ll poww(ll x,ll q)
{
    ll a=x,sum=1;
    while(q)
    {
        if(q&1) sum=sum*a%p;
        q>>=1; a=a*a%p;
    }
    return sum;
}
ll C(ll n,ll m)
{
    if(m>n) return 0;
    ll x=1,y=1;
    while(m)
     {
        x=(x*n)%p;
        y=(y*m)%p;
        n--; m--;
     }
    return x*poww(y,p-2)%p;
}
ll lucas(ll n,ll m)
{
    if (!m) return 1;
    return C(n%p,m%p)*lucas(n/p,m/p)%p;
}
int main()
{
    int i;
    scanf("%I64d",&t);
    for(i=1;i<=t;++i)
     {
        scanf("%I64d%I64d%I64d",&n,&m,&p);
        printf("%I64d\n",lucas(n+m,m));
     }
    return 0;
}
posted @ 2016-04-24 09:12  lris0-0  阅读(91)  评论(0编辑  收藏  举报
过去的终会化为美满的财富~o( =∩ω∩= )m