【bzoj 1042】 [HAOI2008] 硬币购物(dp+容斥原理)
1042: [HAOI2008]硬币购物
Time Limit: 10 Sec Memory Limit: 162 MBSubmit: 1832 Solved: 1071
[Submit][Status][Discuss]
Description
硬币购物一共有4种硬币。面值分别为c1,c2,c3,c4。某人去商店买东西,去了tot次。每次带di枚ci硬币,买s
i的价值的东西。请问每次有多少种付款方法。
Input
第一行 c1,c2,c3,c4,tot 下面tot行 d1,d2,d3,d4,s,其中di,s<=100000,tot<=1000
Output
每次的方法数
Sample Input
1 2 5 10 2
3 2 3 1 10
1000 2 2 2 900
3 2 3 1 10
1000 2 2 2 900
Sample Output
4
27
27
HINT
Source
【题解】【dp+容斥原理 】
#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
using namespace std;
ll f[100010],ans;
int a[5],b[5],tot,val;
void dfs(int x,int y,int val)
{
if(val<0) return;
if(x==5)
{
if(y&1) ans-=f[val];
else ans+=f[val];
return;
}
dfs(x+1,y+1,val-(b[x]+1)*a[x]); dfs(x+1,y,val);
return;
}
int main()
{
int i,j,k;
for(i=1;i<=4;++i) scanf("%d",&a[i]);
f[0]=1;
for(i=1;i<=4;++i)
for(j=a[i];j<=100000;++j)
f[j]+=f[j-a[i]];
scanf("%d",&tot);
for(k=1;k<=tot;++k)
{
for(i=1;i<=4;++i) scanf("%d",&b[i]);
scanf("%d",&val);
ans=0;
dfs(1,0,val);
printf("%lld\n",ans);
}
return 0;
}
既然无能更改,又何必枉自寻烦忧