向前走莫回头❤

【POJ 1018】Communication System(dp|贪心)

Communication System
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 27509   Accepted: 9795

Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices. 
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P. 

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.

Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point. 

Sample Input

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output

0.649

Source

Tehran 2002, First Iran Nationwide Internet Programming Contest

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

【题解】【贪心】
[窝的dp辣么弱。。。当然不会写dp辣!结果,结果就是:浮点数用成G++ WA了半晚上。。。]
【其实是个友好的贪心,在保证b尽量大的前提下,使p尽量小】
【这样,我们可以以b为关键字对所有的排序,从大往小取】

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{
	int num;
	double b,p;
}d[1000010];
int n,T,cnt;
double ans,as[110];
bool vis[110];
int tmp(node x,node y)
{
	return x.b>y.b;
}
int main()
{
	//freopen("int.txt","r",stdin);
	//freopen("my.txt","w",stdout);
	int i,j;
	scanf("%d",&T);
	while(T--)
	 {
	 	memset(vis,0,sizeof(vis));
	 	memset(as,127,sizeof(as));
	 	scanf("%d",&n); cnt=0; ans=0;
	 	for(int i=1;i<=n;++i)
	 	 {
	 	 	int m;
	 	 	scanf("%d",&m);
	 	 	for(int j=1;j<=m;++j)
	 	 	 {
	 	 	 	node x;
	 	 	    scanf("%lf%lf",&x.b,&x.p);
	 	 	    x.num=i;
	 	 	    d[++cnt]=x;
			   }
		  }
		sort(d+1,d+cnt+1,tmp);
		int tot=0; double sum=0;
		for(i=1;i<=cnt;++i)
		 {
		 	int x=d[i].num;
		 	if(!vis[x]) as[x]=d[i].p,vis[x]=1,tot++,sum+=as[x];
			 else
			  if(as[x]>d[i].p) sum-=as[x],as[x]=d[i].p,sum+=as[x];
			  else continue;
			if(tot==n) 
			 {
			 	double ss=d[i].b/sum;
			 	if(ss>ans) ans=ss;
			 } 
		 }
		printf("%.3lf\n",ans);
	 }
	return 0;
}



posted @ 2016-10-20 21:21  lris0-0  阅读(69)  评论(0编辑  收藏  举报
过去的终会化为美满的财富~o( =∩ω∩= )m