【bzoj 2435】[Noi2011]道路修建(dfs)
2435: [Noi2011]道路修建
Time Limit: 10 Sec Memory Limit: 128 MBSubmit: 3505 Solved: 1167
[Submit][Status][Discuss]
Description
在 W 星球上有 n 个国家。为了各自国家的经济发展,他们决定在各个国家
之间建设双向道路使得国家之间连通。但是每个国家的国王都很吝啬,他们只愿
意修建恰好 n – 1条双向道路。 每条道路的修建都要付出一定的费用, 这个费用等于道路长度乘以道路两端的国家个数之差的绝对值。例如,在下图中,虚线所示道路两端分别有 2 个、4个国家,如果该道路长度为 1,则费用为1×|2 – 4|=2。图中圆圈里的数字表示国家的编号。
由于国家的数量十分庞大,道路的建造方案有很多种,同时每种方案的修建
费用难以用人工计算,国王们决定找人设计一个软件,对于给定的建造方案,计
算出所需要的费用。请你帮助国王们设计一个这样的软件。
Input
输入的第一行包含一个整数n,表示 W 星球上的国家的数量,国家从 1到n
编号。接下来 n – 1行描述道路建设情况,其中第 i 行包含三个整数ai、bi和ci,表
示第i 条双向道路修建在 ai与bi两个国家之间,长度为ci。
Output
输出一个整数,表示修建所有道路所需要的总费用。
Sample Input
6
1 2 1
1 3 1
1 4 2
6 3 1
5 2 1
Sample Output
20
HINT
n = 1,000,000 1≤ai, bi≤n
0 ≤ci≤ 10^6
Source
【题解】【dfs】
【裸dfs,有点类似于树链剖分的准备过程,然而这必然不是正解,我几乎卡时。。。】
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{
int s,t,w;
}d[1000010];
int a[2000010],nxt[2000010],p[1000010],val[2000010],tot;
int f[1000010],size[1000010],dep[1000010];
int n;
long long ans;
inline long long abss(int x)
{
if(x>=0) return (long long)x;
x*=-1;
return (long long)x;
}
inline void add(int x,int y,int v)
{
tot++; a[tot]=y; nxt[tot]=p[x]; p[x]=tot; val[tot]=v;
tot++; a[tot]=x; nxt[tot]=p[y]; p[y]=tot; val[tot]=v;
}
void dfs(int x,int fa,int h)
{
f[x]=fa; size[x]=1; dep[x]=h;
for(int i=p[x];i!=-1;i=nxt[i])
if(a[i]!=fa)
{
dfs(a[i],x,h+1);
size[x]+=size[a[i]];
}
return;
}
int main()
{
int i,j;
memset(p,-1,sizeof(p));
memset(nxt,-1,sizeof(nxt));
scanf("%d",&n);
for(i=1;i<n;++i)
{
int x,y,z;
scanf("%d%d%d",&x,&y,&z);
add(x,y,z); d[i].s=x; d[i].t=y; d[i].w=z;
}
dfs(1,0,1);
for(i=1;i<n;++i)
{
int x=d[i].s,y=d[i].t;
int s1,s2;
if(dep[x]>dep[y]) swap(x,y);
s1=size[1]-size[x]+size[x]-size[y]-1;
s2=size[y]-1;
ans+=(long long)abss(s1-s2)*(long long)d[i].w;
}
printf("%lld\n",ans);
return 0;
}
既然无能更改,又何必枉自寻烦忧