向前走莫回头❤

【POJ 1523】SPF(Tarjan求割点)

SPF
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 8246   Accepted: 3767

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

[题意][求一个无向图的中,去掉某一个割点后,图变为几个联通块]
【题解】【Tarjan求割点】
【先求割点,然后有一个结论性的东西】
【如果,i==1&&vis[i]>1,那么联通块的数目为vis[i];如果i!=1&&vis[i],那么联通块的数量为vis[i]+1】
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1000010],nxt[1000010],p[1010],tot;
int dft[1010],dis[1010],vis[1010],cnt;
int n,t;
inline void add(int x,int y)
{
	tot++; a[tot]=y; nxt[tot]=p[x]; p[x]=tot;
	tot++; a[tot]=x; nxt[tot]=p[y]; p[y]=tot;
}
void tarjan(int x)
{
	dft[x]=dis[x]=++cnt;
	for(int i=p[x];i!=-1;i=nxt[i])
	 if(!dft[a[i]])
	  {
	  	tarjan(a[i]);
	  	dis[x]=min(dis[x],dis[a[i]]);
	  	if(dft[x]<=dis[a[i]]) vis[x]++;
	  }
	 else dis[x]=min(dis[x],dft[a[i]]);
}
int main()
{
//	freopen("int.txt","r",stdin);
//	freopen("my.txt","w",stdout);
	int i,j;
	while(1)
	 {
	 	memset(p,-1,sizeof(p));
	 	memset(dft,0,sizeof(dft));
	    memset(dis,0,sizeof(dis));
	    memset(vis,0,sizeof(vis));
	  	memset(nxt,-1,sizeof(nxt));
	    tot=cnt=0; int n=0; bool b=0;
	    int x,y; t++;
	    while(1)
	     {
	     	scanf("%d",&x);
	     	if(!x) break;
	     	if(n<x) n=x;
	     	b=1;
	     	scanf("%d",&y);
	     	if(n<y) n=y;
	     	add(x,y);
		 }
		if(!b) return 0;
		printf("Network #%d\n",t);
		tarjan(1);
		bool b1=0;
		for(i=1;i<=n;++i)
		 if(i==1&&vis[i]>1)
		  {
		  	b1=1;
		  	printf("  SPF node %d leaves %d subnets\n",i,vis[i]);
		  }
		  else
		   if(i!=1&&vis[i]+1>1)
		    {
		   	    b1=1;
		   	    printf("  SPF node %d leaves %d subnets\n",i,vis[i]+1);
		    }
		if(!b1) puts("  No SPF nodes");
		putchar('\n');
	 }
}


posted @ 2016-11-08 00:15  lris0-0  阅读(108)  评论(0编辑  收藏  举报
过去的终会化为美满的财富~o( =∩ω∩= )m