【hdu 1358】Period(kmp)
Period
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7181 Accepted Submission(s): 3455
Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the
largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line,
having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the
prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
[题目大意:从第二个元素开始判断,前缀能否构成循环,且周期不为一,则输出当前是哪一位和循环周期]
【题解】【kmp的失配函数】
【失配函数,循环节=原串长度-末位失配,放在子串中仍然使用,所以逐位判断失配是否满足要求即可】
【注意:每组之间有一行空行】
【注意:每组之间有一行空行】
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[1000010];
int len,t,nxt[1000010];
inline void kmp()
{
int i,j;
nxt[0]=-1;
for (i=0;i<len;++i)
{
j=nxt[i];
while (j!=-1&&s[j]!=s[i]) j=nxt[j];
nxt[i+1]=j+1;
}
return;
}
int main()
{
int i,j;
while ((scanf("%d",&len)==1)&&len)
{
t++;
scanf("%s",s);
printf("Test case #%d\n",t);
kmp();
for (i=1;i<=len;++i)
{
int l=i+1;
j=l-nxt[l];
if (!(l%j)&&l/j>1)
printf("%d %d\n",l,l/j);
}
printf("\n");
}
return 0;
}
既然无能更改,又何必枉自寻烦忧