向前走莫回头❤

【hdu 1711】Number Sequence(kmp)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23191    Accepted Submission(s): 9904


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
6 -1
 

Source

[题目大意:在原串中找子串,输出子串开始出现的位置,如果子串在原串中不存在,则输出-1]
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int s1[1000010],s[10010],n,m,t;
int nxt[10010],ans;
inline void next()
{
    int i,j;
    nxt[0]=-1;
    for (i=0;i<m;++i)
     {
         j=nxt[i];
         while (j!=-1&&s[j]!=s[i]) j=nxt[j];
         nxt[i+1]=j+1;
     }
    return;
}
inline int kmp()
{
    int i=0,j=0;
    while (i<n)
     {
         if (j==-1||s1[i]==s[j]) ++i,++j;
          else j=nxt[j];
         if (j==m) return i-m+1;
     }
    return -1;
}
int main()
{
    int i,j;
    scanf("%d",&t);
    for (i=1;i<=t;++i)
     {
         scanf("%d%d",&n,&m);
         for (j=0;j<n;++j) scanf("%d",&s1[j]);
        for (j=0;j<m;++j) scanf("%d",&s[j]);
        next(); 
        ans=kmp();
        printf("%d\n",ans);
    }
    return 0;
}


 
posted @ 2016-11-08 21:44  lris0-0  阅读(91)  评论(0编辑  收藏  举报
过去的终会化为美满的财富~o( =∩ω∩= )m