【bzoj 3048】[Usaco2013 Jan]Cow Lineup(单调队列)
3048: [Usaco2013 Jan]Cow Lineup
Time Limit: 2 Sec Memory Limit: 128 MBSubmit: 160 Solved: 121
[Submit][Status][Discuss]
Description
Farmer John's N cows (1 <= N <= 100,000) are lined up in a row. Each cow is identified by an integer "breed ID" in the range 0...1,000,000,000; the breed ID of the ith cow in the lineup is B(i). Multiple cows can share the same breed ID. FJ thinks that his line of cows will look much more impressive if there is a large contiguous block of cows that all have the same breed ID. In order to create such a block, FJ chooses up to K breed IDs and removes from his lineup all the cows having those IDs. Please help FJ figure out the length of the largest consecutive block of cows with the same breed ID that he can create by doing this.
Input
* Line 1: Two space-separated integers: N and K.
* Lines 2..1+N: Line i+1 contains the breed ID B(i).
Output
* Line 1: The largest size of a contiguous block of cows with identical breed IDs that FJ can create.
Sample Input
2
7
3
7
7
3
7
5
7
INPUT DETAILS: There are 9 cows in the lineup, with breed IDs 2, 7, 3, 7, 7, 3, 7, 5, 7. FJ would like to remove up to 1 breed ID from this lineup.
Sample Output
OUTPUT DETAILS: By removing all cows with breed ID 3, the lineup reduces to 2, 7, 7, 7, 7, 5, 7. In this new lineup, there is a contiguous block of 4 cows with the same breed ID (7).
HINT
Source
【题解】【单调队列】
【维护一个含有k+1种元素的单调队列。首先在初始的时候,存每个元素的序号,然后将元素排序,便于记录有多少种不同的情况。在维护队列时,如果超过k+1种,就把前面的元素一一删,删至剩k+1种元素,每次向队列里加元素时都要比较当前的最优解和当前的元素出现次数的大小关系】
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[100010],kind[100010],num[100010],d[100010],h,n,k;
int ans;
inline int tmp(int x,int y)
{
return a[x]<a[y];
}
int main()
{
int i,j;
scanf("%d%d",&n,&k);
for(i=1;i<=n;++i) scanf("%d",&a[i]),num[i]=i;
sort(num+1,num+n+1,tmp);
a[0]=-1; int tot=0;
for(i=1;i<=n;++i)
{
if(a[num[i-1]]!=a[num[i]]) tot++;
kind[num[i]]=tot;
}
tot=0;
for(i=1;i<=n;++i)
{
++d[kind[i]];
if(d[kind[i]]==1)
{
tot++;
while (tot>k+1)
{
d[kind[h]]--;
if (!d[kind[h]]) tot--;
h++;
}
}
ans=max(ans,d[kind[i]]);
}
printf("%d\n",ans);
return 0;
}