【POJ 2823】Sliding Window(单调队列)
Sliding Window
Description
An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window
moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Your task is to determine the maximum and minimum values in the sliding window at each position. Input
The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Input 8 3 1 3 -1 -3 5 3 6 7 Sample Output -1 -3 -3 -3 3 3 3 3 5 5 6 7 Source
POJ Monthly--2006.04.28, Ikki
|
[Submit] [Go Back] [Status] [Discuss]
【题解】【单调队列模板题】
#include<cstdio>
#include<cstring>
using namespace std;
int a[1000010],p[1000010],h,t,n,k;
void pushmin(int i)
{
while(h!=t&&a[p[t]]>a[i]) t--;
t++; p[t]=i;
return;
}//维护递增的单调队列
void pushmax(int i)
{
while(h!=t&&a[p[t]]<a[i]) t--;
t++; p[t]=i;
return;
}//维护递减的单调队列
int main()
{
int i,j;
scanf("%d%d",&n,&k);
for(i=1;i<=n;i++) scanf("%d",&a[i]);
h=t=0;
for(i=1;i<=k;i++) pushmin(i);
printf("%d ",a[p[h+1]]);
for(i=k+1;i<=n;i++)
{
while(h!=t&&p[h+1]<=i-k) h++;
pushmin(i);
printf("%d ",a[p[h+1]]);
}//维护最小值的单调队列
memset(p,0,sizeof(p));
h=t=0;
for(i=1;i<=k;i++) pushmax(i);
printf("\n%d ",a[p[h+1]]);
for(i=k+1;i<=n;i++)
{
while(h!=t&&p[h+1]<=i-k) h++;
pushmax(i);
printf("%d ",a[p[h+1]]);
}//维护最大值的单调队列
return 0;
}//只是一个裸裸的单调队列(好吧,其实我是刚学的)
既然无能更改,又何必枉自寻烦忧