向前走莫回头❤

【hdu 2669】Romantic(扩展欧几里得)

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5424    Accepted Submission(s): 2287


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
 

Sample Input
77 51 10 44 34 79
 

Sample Output
2 -3 sorry 7 -3
 

Author
yifenfei
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2668 2674 2671 2670 2672 
 

【题解】【扩展欧几里得】

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
using namespace std;
ll a,b,ans;
ll gcd(ll a,ll b,ll &x,ll &y)
{
	if(!b) {x=1; y=0; return a;}
	ll d=gcd(b,a%b,x,y);
	ll t=x; x=y; y=t-a/b*y;
	return d;
}
inline ll exgcd(ll a,ll b,ll c)
{
	ll x,y;
	ll d=gcd(a,b,x,y);
	if(c%d) return -1;
	x*=c/d; b/=d;
	if(b<0) b=-b;
	ll sum=x%b;
	if(sum<=0) sum+=b;
	return sum; 
}
int main()
{
	while(scanf("%I64d%I64d",&a,&b)==2)
	 {
	 	ans=exgcd(a,b,1);
	 	if(ans==-1) {printf("sorry\n"); continue;}
	 	printf("%I64d %I64d\n",ans,(1-ans*a)/b);
	 }
}


posted @ 2016-11-13 07:27  lris0-0  阅读(107)  评论(0编辑  收藏  举报
过去的终会化为美满的财富~o( =∩ω∩= )m