【hdu 1695】GCD(莫比乌斯反演)
GCD
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10201 Accepted Submission(s): 3849
Problem Description
Given 5 integers: a, b, c, d, k, you’re to find x in a…b, y in c…d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you’re only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.
Yoiu can assume that a = c = 1 in all test cases.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
Output
For each test case, print the number of choices. Use the format in the example.
Sample Input
2
1 3 1 5 1
1 11014 1 14409 9
Sample Output
Case 1: 9
Case 2: 736427
HintFor the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
Source
2008 “Sunline Cup” National Invitational Contest
Recommend
wangye | We have carefully selected several similar problems for you: 1689 1690 1693 1691 1698
[题意][求
【题解】
设
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int prime[100010],miu[100010];
int a,b,c,d,k,t;
bool p[100010];
inline void shai(int n)
{
int i,j;
miu[1]=1;
for (i=2;i<=n;++i)
{
if(!p[i]) prime[++prime[0]]=i,miu[i]=-1;
for (j=1;j<=prime[0];++j)
{
if (i*prime[j]>n) break;
p[i*prime[j]]=1;
if (!(i%prime[j])) {miu[i*prime[j]]=0;break;}
else miu[i*prime[j]]=-miu[i];
}
}
}
int main()
{
int i,j;
scanf("%d",&t);
shai(100000);
for (i=1;i<=t;++i)
{
scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
if (!k) {printf("Case %d: 0\n",i); continue;}
long long ans1=0,ans2=0;
b/=k; d/=k;
if (b>d) swap(b,d);
for (j=1;j<=b;++j) ans1+=(long long)(b/j)*(d/j)*miu[j];
for (j=1;j<=b;++j) ans2+=(long long)(b/j)*(b/j)*miu[j];
ans1-=ans2/2;
printf("Case %d: %I64d\n",i,ans1);
}
return 0;
}