hdu-1907 John

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1907

题目类型:

博弈

题意描述:

有N个装有若干个糖果的盒子,有两个人轮流取盒子中的糖果,每次只能从一个盒子中拿不少于1个糖果(可以一次性取完)直到所有糖果都取完,最后一次取糖果的人输,问john是胜是负。

解题思路:

该题是nim博弈的变形,先进行一次判断是否所有的盒子中全都是1个糖果,如果这样,结果已定,如果不是,则对每一堆糖果的个数进行异或运算,如果最终值为0,则John输,反之则John胜。

题目:

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4816    Accepted Submission(s): 2780


Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

 

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 

 

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

 

Sample Input
2
3
3 5 1
1
1
 
 

 

Sample Output
John
Brother
 

 

# include <stdio.h>

int game(int a[],int n)
{
    int i,num,ret;
    ret=0;
    for(i=0;i<n;i++)
        if(a[i]!=1)
            ret=1;
    if(ret==0)
    {
        if(n%2==0)
            return 1;
        else
            return 0;
    }
    num=0;
    for(i=0;i<n;i++)
        num=num^a[i];
    if(num!=0)
        return 1;
    else
        return 0;
}

int main ()
{
    int t,n,i,a[50];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        if(game(a,n)==1)
            printf("John\n");
        else
            printf("Brother\n");
    }
    return 0;
}

 

posted @ 2017-06-09 00:38  枫兮云兮君兮  阅读(222)  评论(0编辑  收藏  举报