hdu-1358 Period

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1358

题目类型:

字符串-KMP

题意概括:

找出从第二个字符开始,之前所有的字符是否是循环串,如果是,输出当前字符的下标(此题下标从1开始)和周期(T>1)

解题思路:

通过KMP算法找出循环,并通过下标相减判断循环节。

题目:

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8105    Accepted Submission(s): 3902


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

 

Sample Input
3
aaa
12
aabaabaabaab
0
 

 

Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
# include <stdio.h>
# define MAX 1000010

char a[MAX];
int l,next[MAX];

void get_next()
{
    int i,j;
    i=0; j=-1;
    next[0]=-1;
    while(i<l)
    {
        if(j==-1 || a[i]==a[j])
        {
            i++; j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}

void kmp()
{
    int k,i;
    for(i=2;i<=l;i++)
    {
        k=i-next[i];
        if(i!=k && i%k==0)
            printf("%d %d\n",i,i/k);
    }
}

int main ()
{
    int ret=0;
    while(scanf("%d",&l),l)
    {
        ret++;
        getchar();
        gets(a);
        get_next();
        printf("Test case #%d\n",ret);  
        kmp();
        printf("\n");
    }
 } 

 

 

posted @ 2017-06-04 23:40  枫兮云兮君兮  阅读(192)  评论(0编辑  收藏  举报