hdu-1088 Write a simple HTML Browser

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1088

题目类型:

字符串的简单模拟

题意概括:

对于给出的一堆字符串,当遇到<br>换行,遇到<hr>输出20个-并换行

解题思路:

根据题意模拟即可。

题目:

Write a simple HTML Browser

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12093    Accepted Submission(s): 3497


Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed. 
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do? 
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags) <br> which is a linebreak and <hr> which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.
 

 

Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines. 
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>.
 

 

Output
You should display the the resulting text using this rules: 
  . If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line. 
  . If you read a <br> in the input, start a new line. 
  . If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again). 
The last line is ended by a newline character.
 

 

Sample Input
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. <br> Zwei <br> <br> produzieren zwei Newlines. Es gibt auch noch das tag <hr> was einen Trenner darstellt. Zwei <hr> <hr> produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
 

 

Sample Output
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. Zwei produzieren zwei Newlines. Es gibt auch noch das tag -------------------------------------------------------------------------------- was einen Trenner darstellt. Zwei -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
 
# include <stdio.h>
# include <string.h>

int main ()
{
    int l,ret=0;
    char a[5000];
    while(scanf("%s",a)!=EOF)
    {
        
        if(a[0]=='<'&&a[1]=='b'&&a[2]=='r'&&a[3]=='>')
            {
                printf("\n");
                ret=0;
                continue;
            }
        if(a[0]=='<'&&a[1]=='h'&&a[2]=='r'&&a[3]=='>')
        {
            if(ret!=0)
                printf("\n");
            printf("--------------------------------------------------------------------------------\n");    
            ret=0;
            continue;
        }
        
        l=strlen(a);
        if(ret==0)
        {
            printf("%s",a);
            ret+=l;
            continue;
        }
        if(ret+l+1<=80)
        {
            printf(" %s",a);
            ret+=l+1;
        }
        else if(ret+1+l>80)
        {
            printf("\n",ret);
            printf("%s",a);
            ret=l;
        }
    }
    printf("\n");
    return 0;
}

 

posted @ 2017-06-04 19:29  枫兮云兮君兮  阅读(281)  评论(0编辑  收藏  举报