hdu-1013 Digital Roots

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1013

题目类型:

数论

题意概括:

把一个数的每一位数字都相加,如果和大于10,则再次进行上一步操作,直到和小于10,后输出。

题目:

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 78428    Accepted Submission(s): 24527


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

 

Sample Input
24
39
0
 

 

Sample Output
6
3
 
易出错分析:
在刚拿到这道题的时候,年轻的我直接用int,结果给我一个TLE,后来用了long long 结果依旧,最后换成字符串类型的,直接AC

# include <stdio.h>
# include <math.h>
# include <string.h>
int main ()
{
    int l,sum,ret,i;
    char a[1200];
    while(scanf("%s",a))
    {
        l=strlen(a);
        if(l==1 && a[0]=='0')
            break;
        sum=0;
        for(i=0;i<l;i++)
            sum+=a[i]-'0';
        
        
        while(sum>=10)
        {
            ret=0;
            l=(int)log10(sum)+1;
            for(i=0;i<l;i++)
            {
                ret+=sum%10;
                sum/=10;
            }
            sum=ret;
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

 

 

posted @ 2017-06-04 18:22  枫兮云兮君兮  阅读(141)  评论(0编辑  收藏  举报