The Accomodation of Students
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5451 Accepted Submission(s): 2491
Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.
Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.
Calculate the maximum number of pairs that can be arranged into these double rooms.
Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.
Calculate the maximum number of pairs that can be arranged into these double rooms.
Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.
Proceed to the end of file.
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.
Proceed to the end of file.
Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
Sample Output
No
3
题目大意:有n个学生,有m对人是认识的,每一对认识的人能分到一间房,问能否把n个学生分成两部分,每部分内的学生互不认识,而两部分之间的学生认识。如果可以分成两部分,就算出房间最多需要多少间,否则就输出No。
思路:二分判定用染色法,找最大匹配数用匈牙利算法
代码:
#include <iostream>
#include <vector>
#include <cstring>
#include <cstdio>
const int MAX=1e5+5;
using namespace std;
vector<int>mp[MAX];
int d[MAX],n,m,vis[MAX],link[MAX];
int dfs(int x,int f) //染色法
{
d[x]=f;
for(int i=0; i<mp[x].size(); i++)
{
if(d[x]==d[mp[x][i]])
return 0;
int u=mp[x][i];
if(d[u]==0)
if(!dfs(u,-f))
return 0;
}
return 1;
}
int dfs2(int x) //找最大匹配
{
for(int i=0; i<mp[x].size(); i++)
{
int v=mp[x][i];
if(!vis[v])
{
vis[v]=1;
if(link[v]==-1||dfs2(link[v]))
{
link[v]=x;
return 1;
}
}
}
return 0;
}
int find() //找最大匹配
{
int res=0;
memset(link,-1,sizeof(link));
for(int i=1; i<=n; i++)
{
memset(vis,0,sizeof(vis));
if(dfs2(i))
res++;
}
return res;
}
int main()
{
int a,b;
while(cin>>n>>m)
{
for(int i=1; i<=n; i++)
if(mp[i].size())
mp[i].clear();
for(int i=0; i<m; i++)
{
scanf("%d%d",&a,&b);
mp[a].push_back(b);
mp[b].push_back(a);
}
int flag=1;
memset(d,0,sizeof(d));
for(int i=1; i<=n; i++) //染色
{
if(mp[i].size())
if(!d[i])
if(!dfs(i,1))
{
flag=0;
break;
}
}
if(!flag)
cout<<"No"<<endl;
else
{
cout<<find()/2<<endl;
}
}
}
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】凌霞软件回馈社区,博客园 & 1Panel & Halo 联合会员上线
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· SQL Server 内存占用高分析
· .NET Core GC计划阶段(plan_phase)底层原理浅谈
· .NET开发智能桌面机器人:用.NET IoT库编写驱动控制两个屏幕
· 用纯.NET开发并制作一个智能桌面机器人:从.NET IoT入门开始
· 一个超经典 WinForm,WPF 卡死问题的终极反思
· 20250116 支付宝出现重大事故 有感
· 一个基于 Roslyn 和 AvalonEdit 的跨平台 C# 编辑器
· 2025 最佳免费商用文本转语音模型: Kokoro TTS
· 海康工业相机的应用部署不是简简单单!?
· 在 .NET Core中如何使用 Redis 创建分布式锁