随笔- 107  文章- 0  评论- 6  阅读- 96196 
Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 41928   Accepted: 12886

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题目大意:判断俩人是否一个集团,但给的信息是谁和谁不是一个集团的,考的是祖宗节点的距离
题目链接:http://poj.org/problem?id=1703

代码:
#include <iostream>
#include <cstring>
#include <cstdio>
const int MAX=1e5+5;
using namespace std;
int rea[MAX],f[MAX];
int find(int n)
{
    if(n==f[n])
    return n;
    int tmp=f[n];
    f[n]=find(f[n]);
    rea[n]=(rea[tmp]+rea[n])%2;
    return f[n];
}
int main()
{ int t,n,m;
 cin>>t;
while(t--)
{
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        f[i]=i;
        rea[i]=0;
    }
    char a[10];
    int b,c;
    for(int i=0;i<m;i++)
    {
        scanf("%s",a);
        if(a[0]=='D')
        {
            scanf("%d%d",&b,&c);
            int b1=find(b),c1=find(c);
            if(b1!=c1)
            {
                    f[b1]=c1;
                    rea[b1]=(rea[b]+rea[c]+1)%2;
            }
        }
        else
        {
            scanf("%d%d",&b,&c);
            int b1=find(b),c1=find(c);
            if(b1==c1)
            {
                if(rea[b]==rea[c])
               printf("In the same gang.\n");
                else
                printf("In different gangs.\n");

            }
            else
            printf("Not sure yet.\n");
        }
    }



}
    return 0;
}
 
 
 
 posted on   几缕清风依旧  阅读(429)  评论(0编辑  收藏  举报
编辑推荐:
· SQL Server 内存占用高分析
· .NET Core GC计划阶段(plan_phase)底层原理浅谈
· .NET开发智能桌面机器人:用.NET IoT库编写驱动控制两个屏幕
· 用纯.NET开发并制作一个智能桌面机器人:从.NET IoT入门开始
· 一个超经典 WinForm,WPF 卡死问题的终极反思
阅读排行:
· 20250116 支付宝出现重大事故 有感
· 一个基于 Roslyn 和 AvalonEdit 的跨平台 C# 编辑器
· 2025 最佳免费商用文本转语音模型: Kokoro TTS
· 海康工业相机的应用部署不是简简单单!?
· 在 .NET Core中如何使用 Redis 创建分布式锁
点击右上角即可分享
微信分享提示