Ants POJ 1852

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8

38 207

//大意就是找出最大最小的时间,蚂蚁都掉下去了

//能够这样想,当两仅仅蚂蚁相碰时。不是都要向回走吗?能够理解成两仅仅蚂蚁是一样的,就相当于两仅仅蚂蚁互不影响,即使相碰他还是接着先前走。

AC代码

#include <stdio.h>
#include <string.h>
#define INF 0x3f3f3f3f
#define M 1000000
int min[M], max[M];
int main()
{
	int len, N, temp;
	int left, right;
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d", &len, &N);
		for(int i = 1; i <= N; ++i){
			scanf("%d",&temp);
			left = temp;
			right = len-temp;
			if(left>right){
				min[i] = right;
				max[i] = left;
			}
			else
			{
				min[i] = left;
				max[i] = right;
			}
		}
		int Min=-INF, Max=-INF;
		for(int i = 1; i <= N; ++i){
			if(min[i] > Min) Min = min[i];
			if(max[i] > Max) Max = max[i];
		}
		printf("%d %d\n", Min, Max);
	}
	
	return 0;
}



posted @ 2018-02-19 16:37  llguanli  阅读(135)  评论(0编辑  收藏  举报