龙姑娘  

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 

Input

* Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 

Output

* Line 1: A single integer that is the median milk output.
 

Sample Input

5 2 4 1 3 5
 

Sample Output

3

解题思路:

         简单的排序问题,平时排序问题虽说简单可是比较繁琐(冒泡法、选择法、折半查找) ,STL中自带了排序函数sort用起来非常方便让你从排序中解放出来。

 

给出两种不同方法读者自行比较:

代码一常规方法:

#include "cstdio"
#include "iostream"
#include "cstring"
#include "algorithm"
using namespace std;

int main()
{
    int a[10000];
    int n,m;
    while(scanf("%d",&n)!=EOF)
   {
      memset(a,0,sizeof(a));
    for(int i=0;i<n;i++)
    scanf("%d",&a[i]);
    for(int i=0;i<n-1;i++)
    for(int j=i+1;j<n;j++)
    if(a[i]>a[j])
    {
        m=a[i];
        a[i]=a[j];
        a[j]=m;

    }
    printf("%d\n",a[n/2]);}
    return 0;
}

 

代码二(sort):

 

#include "cstdio"
#include "iostream"
#include "cstring"
#include "algorithm"
using namespace std;

int main()
{
    int a[10000];
    int n,m;
    while(scanf("%d",&n)!=EOF)
   {
      memset(a,0,sizeof(a));
    for(int i=0;i<n;i++)
    scanf("%d",&a[i]);
    sort(a,a+n);
    printf("%d\n",a[n/2]);}
    return 0;
}

  

 

posted on 2016-07-24 20:14  龙姑娘  阅读(177)  评论(0编辑  收藏  举报