poj 2398 Toy Storage

Toy Storage
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3349   Accepted: 1929

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

第一道计算几何的题
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct node
{
     double x1,y1,x2,y2;
}p[1005];
bool cmp(node a,node b)
{
     double mina=min(a.x1,a.x2);
     double minb=min(b.x1,b.x2);
     return mina<minb;
}
struct point
{
     double x,y;
}q;
int solve(point a,point b,point c)//叉积判断方向,暂且可把2条线段构成的图形看成一个矩形,从逆时针方向看,如果这个点在矩形内
{
     return (a.x-b.x)*(c.y-b.y)-(c.x-b.x)*(a.y-b.y);//那么这个点必然在4条线段的左边,可以画画图
}
int judge(point t,node e,node f)//调整为4个点,方便判断
{
     point a,b,c,d;
     a.x=e.x1,a.y=e.y1;
     b.x=e.x2,b.y=e.y2;
     c.x=f.x2,c.y=f.y2;
     d.x=f.x1,d.y=f.y1;
     if(solve(a,t,b)>=0&&solve(b,t,c)>=0&&solve(c,t,d)>=0&&solve(d,t,a)>=0)//如果叉积还回的值大于等于0就说明该点在该线段的左边
          return 1;
     return 0;
}
int num[1005];
int a[1005];
int main()
{
     int n,m,i,j;
     double x1,y1,x2,y2,x,y;
     while(scanf("%d",&n)!=EOF,n)
     {
          memset(num,0,sizeof(num));
          memset(a,0,sizeof(a));
          scanf("%d%lf%lf%lf%lf",&m,&x1,&y1,&x2,&y2);
          p[0].x1=x1;p[0].x2=x1;//补充最左边和最右边的板子
          p[0].y1=y1;p[0].y2=y2;
          p[n+1].x1=x2;p[n+1].x2=x2;
          p[n+1].y1=y1;p[n+1].y2=y2;
          for(i=1;i<=n;i++)
          {
               scanf("%lf%lf",&x1,&x2);
               p[i].x1=x1;p[i].x2=x2;
               p[i].y1=y1;p[i].y2=y2;
          }
          sort(p,p+n+2,cmp);//排序,因为给出的板子也就是线段不一定是排好序的,按照线段的左端点从小到大排序
        for(i=1;i<=m;i++)
        {
             scanf("%lf%lf",&q.x,&q.y);
              for(j=0;j<=n;j++)//对于每一个点都判断一下,它是否在这个箱子内,是的话该箱子的点数加一,跳出循环
             if(judge(q,p[j],p[j+1]))
             {
                   num[j]++;
                   break;
             }

        }
        for(i=0;i<=n+1;i++)
        {
             if(num[i])
                   a[num[i]]++;//统计有num[i]个点的箱子的个数
        }
        printf("Box\n");
        for(i=1;i<=n;i++)
          if(a[i])
          printf("%d: %d\n",i,a[i]);
     }
     return 0;
}

 

posted @ 2013-08-23 10:10  SprayT  阅读(148)  评论(0编辑  收藏  举报