hdu 1514 Stars

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3573    Accepted Submission(s): 1396


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

 

Sample Input
5 1 1 5 1 7 1 3 3 5 5
 

 

Sample Output
1 2 1 1 0
 树状数组

 这题注意一下x是从0开始的,所以对于所有的这样并不影响最终的结果

#include<stdio.h>
#include<string.h>
int level[40000];
int c[40000];
int lowbit(int x)
{
     return x&(-x);
}
void add(int x,int k)
{
     while(x<=32000)
     {
          c[x]+=k;
          x+=lowbit(x);
     }
}
int Sum(int x)
{
     int sum=0;
     while(x>0)
     {
          sum+=c[x];
          x-=lowbit(x);

     }
    // printf("sum=%d\n",sum);
     return sum;
}
int main()
{
     int i,n,a,b,cc,p;
     while(~scanf("%d",&n))
     {
          memset(level,0,sizeof(level));
          memset(c,0,sizeof(c));
          for(i=1;i<=n;i++)
          {
               scanf("%d %d",&a,&b);
              level[Sum(++a)]++;
             //  printf("level[%d]=%d\n",p,cc);
               add(a,1);

          }
        for(i=0;i<n;i++)
          printf("%d\n",level[i]);
     }
     return 0;
}

 

posted @ 2013-08-14 19:19  SprayT  阅读(127)  评论(0编辑  收藏  举报