poj 1068 Parencodings

Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17066   Accepted: 10221

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

//模拟题,先将右括号补齐
//用一个数组记录左括号为0,右括号为1
//然后扫一遍
#include<stdio.h>
#include<string.h>
int a[200000];//p序列
int b[200000];//整个括号用0与1表示
int c[200000];//w序列
int main()
{
     int i,j,n,t,k,cnt,ans,p,flag;
     scanf("%d",&t);
     while(t--)
     {

          flag=0;
          scanf("%d",&n);
         for(i=1;i<=n;i++)
         scanf("%d",&a[i]);
         k=0;
          for(i=1;i<=n;i++)
          {

               for(j=0;j<a[i]-a[i-1];j++)//补齐左括号
               {
                    b[k++]=0;

               }
               b[k++]=1;//补齐右括号

          }

         p=0;
         for(i=0;i<2*n;i++)//最多有2*n个括号
         {
              cnt=1;
              ans=1;
              flag=0;

              if(b[i]==1)
              {
                k=i;
                   flag=1;


                   for(j=i-1;j>=0;j--)//从右往左扫
                   {
                        if(b[j]==1)
                        {
                             ans++;//记录右括号的数目,也就是匹配好了的括号数
                             cnt++;//右括号加1
                        }
                        else
                        cnt--;//左括号减1

                        if(cnt==0)//cnt记录的是左右括号的数目,如果相抵消就跳出
                        break;
                   }

              }
              if(flag)
              {
                   c[p++]=ans;
                   i=k;//i是不断往前走的
              }

         }
         for(i=0;i<n;i++)
         printf("%d%c",c[i],i==n-1?'\n':' ');
     }
     return 0;
}

 

posted @ 2013-07-30 10:33  SprayT  阅读(177)  评论(0编辑  收藏  举报