代码改变世界

poj 1503 Integer Inquiry

2012-03-27 16:18  璋廊  阅读(172)  评论(0编辑  收藏  举报

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself. 

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

Source

 

题是非常简单!就是大整数加法位数不会超过一百位,但是有个陷阱!哎我很显然掉下啦!题中会提到的!

代码如下:

#include<stdio.h>
#include<string.h>
int main()
{
 int k,i,j;
 char a[101];
 int a1[201];
 memset(a1,0,sizeof(a1));//初始化!
 while(gets(a),strcmp(a,"0")!=0)//如果用是s[i]!='0';是过不去的!
 {
 
	 k=strlen(a);j=0;
	 for(i=k-1;i>=0;i--)
	{
	 a1[j]+=a[i]-'0';
	 if(a1[j]>=10)
		{
		a1[j+1]+=a1[j]/10;
		a1[j]=a1[j]%10;
   
		}
	j++;
	}
	}
		int p=0;
	 for(i=200;i>=0;i--)//去掉前导零
	 {
	  if(a1[i]&&p==0)
	  {
	   printf("%d",a1[i]);
	   p=1;
	   continue;
	  }
	  if(p==1)
	   printf("%d",a1[i]);
	 }
	  printf("\n");
	return 0;
}