代码改变世界

poj 1250 Tanning Salon

2012-03-27 12:57  璋廊  阅读(190)  评论(0编辑  收藏  举报
Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning.

Input

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.

Output

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.

Sample Input

2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0

Sample Output

All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.
题目的大概意思就是旅馆有n个位置,ABC等每个大写字母代表一个人,出现第一次代表来,出现第二次代表回去,如果没有空位,就要离开;求离开的人数,
思路很新看别人是代码是自己写的
代码如下:、
提示 由于只有大写字母,我们可以利用其下标的关系思路清晰,简单
#include<stdio.h>
#include<string.h>
int main()
{ 
	int n,i,k,sum,id; 
	char a[101];
	while(scanf("%d",&n),n) 
	{  scanf("%s",a);  
	int b[50]={0};//初始化0代表没有来过  
	int c[50]={0};  
	k=strlen(a);  
	sum=0;  
	for(i=0;i<k;i++) 
	{   id=a[i]-'A';  
	if(b[id]==0)   
	{     b[id]=1;//代表来过  
	if(n>0)  
		{    
		n--;   
		c[id]=1; 
		} 
		else   
		{     
		sum++; 
		} 
  }  
	else
	{   
		if(c[id]) 
			n++;  
 }  
} 
	if(sum==0)
		printf("All customers tanned successfully.\n");  
	else printf("%d customer(s) walked away.\n",sum);
 } 
	return 0;
}