hdu 5019(第K大公约数)

Revenge of GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2140    Accepted Submission(s): 596


Problem Description
In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.
 

 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers X, Y and K.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= X, Y, K <= 1 000 000 000 000
 

 

Output
For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.
 

 

Sample Input
3 2 3 1 2 3 2 8 16 3
 

 

Sample Output
1 -1 2
 

 

Source
 
被坑惨了。。GCD的参数传的INT。。求出最大公约数然后求最大公约数的第K大因子就好。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<math.h>
#include<queue>
#include<iostream>
using namespace std;
typedef long long LL;
LL gcd(LL a,LL b){
    return b==0?a:gcd(b,a%b);
}
LL p[10005];
LL cmp(LL a,LL b){
    return a>b;
}
int main()
{
    int tcase;
    scanf("%d",&tcase);
    while(tcase--){
        LL a,b,k;
        scanf("%lld%lld%lld",&a,&b,&k);
        LL d = gcd(a,b);
        int id = 0;
        for(LL i=1;i*i<=d;i++){ ///筛选出所有因子
            if(d%i==0){
                 if(i*i==d) p[id++]=i;
                 else{
                    p[id++]=i;
                    p[id++]=d/i;
                 }
            }
        }
        if(id<k){
            printf("-1\n");
        }
        else{
            sort(p,p+id,cmp);
            printf("%lld\n",p[k-1]);
        }
    }
    return 0;
}

 

posted @ 2016-06-10 11:26  樱花庄的龙之介大人  阅读(392)  评论(0编辑  收藏  举报