hdu 2104(判断互素)

hide handkerchief

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3970    Accepted Submission(s): 1884


Problem Description
The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".
 

 

Input
There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.
 

 

Output
For each input case, you should only the result that Haha can find the handkerchief or not.
 

 

Sample Input
3 2 -1 -1
 

 

Sample Output
YES
 
题意:n个人围成的一个圈,其中有一个人的盒子里面有一个漂亮的帽子,haha从1号开始找,每隔m-1个人找一次,问他最后是否一定能够找到这个帽子。
题解:一定找到这个帽子的话就每个人都要找一遍,n,m互素.
#include <stdio.h>
using namespace std;
int gcd(int a,int b){
    return b==0?a:gcd(b,a%b);
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF,n!=-1&&m!=-1){
        if(gcd(n,m)!=1) printf("POOR Haha\n");
        else printf("YES\n");
    }
    return 0;
}

 

posted @ 2016-05-24 21:42  樱花庄的龙之介大人  阅读(395)  评论(0编辑  收藏  举报